Jump to content
JohnnySmith004

PR BF 2 has closed ,cleaning up resources

Recommended Posts

hey guys , for a few weeks now i've had a problem - my PR won't startup ,always when i click on play it loads my account -short blackscreen and then it just says "PR:BF2 has closed , cleaning up resources
pr-closed.png

i've already tried :Reinstalling PR ,Reinstalling NET.Framework , DirectX(old version),launching in window mode and lower resolution windowed-800x480.png and deleting and recreating new account - nothing worked

has anyone of you ever had this problem and fixed it? Please let me know how you've done it i wanna play the game again xD - Looking forward to answers

Sincerely - Jonas

Edited by =VG= SemlerPDX
added pics

Share this post


Link to post
Share on other sites

try to create an offline accout and see if it works with it.

do you have multiple sound or graphics cards?
have you ever been able to play pr on this computer?
do you start the game in admin mode?
firewall and antivirus software you could also switch to off and try if it works. but turn back on afterwards !!!
in the launcher there are options to delete the cache and all other settings, which you could also try.

  • Like 1

Share this post


Link to post
Share on other sites

This is pretty specific to the Project Reality Mod, and they have a troubleshooting section over there that the Devs monitor, where you might get swifter answers direct from the source, though many here are long time regulars of the game, some of the Devs have answered many more issues just like this and might have insights we miss.  Just FYI.  At least start a post over there, too - see which one of these gets resolved faster.  We're all pretty much one giant team in the general sense through our interest of Project Reality, but since they made it, they've surely run through the technical troubleshooting so much that it's second nature.  Might wanna provide just a few specific details, too, such as OS, current DirectX version, not sure what they'd want - you can ask tho.

Best wishes and good luck!!

Share this post


Link to post
Share on other sites

Hello guys 

Well , the dev didnt find a solution and isnt even answering anymore so i guess thats it , and yes i've already played the game , and also on your server thats why i'm here .

so , well ,just wanted to thank you,i had a great experience ,and you guys are the nicest so far, maybe we'll see again.

have a good one -Jonas

  • Upvote 1

Share this post


Link to post
Share on other sites

Right.  So, what they were trying to get you to do the things that may help troubleshoot your issue, yet I don't see that happening.  How can they help you if you cannot help yourself?

The game is not reading or writing the profile folder correctly, or the resolution is wrong.  We can't help, we didn't write the game.  Can you maybe try disabling your anti-virus for a test?  Not sure that we can do anything more than the people who literally coded the game.

I understand your frustration, but you need to troubleshoot step-by-step.  Step one would be following what was instructed, then reporting back.  If that doesn't work, let them know so you can try something different.

 

Wish I could help - best wishes and good luck!

 

 

Quote

AlonTavor wrote ...


Delete the PR folder in my documents and run the launcher as admin. That's what always solves it.


Its just the default one when the game cant read the settings file

Quote

AlonTavor wrote ...


The issue is either the launcher is unable to write the profile files or the game is unable to read the profile files, or you set this bad resolution on the Launcher.

The files are in:
C:\Users\USERNAME\Documents\ProjectReality\Profiles\(Number of your profile in launcher)

Edited by =VG= SemlerPDX
added solution from Alon

Share this post


Link to post
Share on other sites

Change line 9 in:

documents/projectreality/profiles/0001

so it reads:

VideoSettings.setResolution 1920x1080@60Hz (insert the resolution you currently run)...

Change line 9 in:

documents/projectreality/profiles/default

so it reads:

VideoSettings.setResolution 1920x1080@60Hz (again insert the resolution you currently run)...

Run this command:

simultaneously clicking windows key and 'R'

enter dxdiag into the run dialogue box...

Click display on the top tabs, look for the line "Feature Levels" in the right hand dialogue box, if it does not match this line:

 Feature Levels: 12_1,12_0,11_1,11_0,10_1,10_0,9_3,9_2,9_1

then download the following file and install:

https://www.microsoft.com/en-gb/download/details.aspx?id=34429

Once installed... right click the PR icon and run as administrator.

 

  • Upvote 3

Share this post


Link to post
Share on other sites

The Feature levels match and resolutions are set, tried reinstalling again and also reinstalling driver , did not work ,and i've already downloaded that file a few times, dunno what im gonna do now but i guess imma research a bit more and maybe find some fixes , Thanks for helping

Share this post


Link to post
Share on other sites

Check this link:

https://steamcommunity.com/app/24860/discussions/0/864951657945537942/?l=french


Some solutions in the link (Just so you dont waste time to read it all):

Solution 1

Hey! So what *my* problem was is my laptop came with two different graphics card. a Nvidia 730m, and the more basic integrated graphics card that's in the system. So, of course I automatically have it set so every game uses the Nvidia card, but BF2 is apparently no compatible with that exact card (I guess?). So I ran it with the integrated crappier graphics card and it worked fine (so far!) lol. Now it's just a matter of trying to run Project Reality successfully! hah.

Solution 2

Hello everyone.
After searching many forums and having absolutely no luck with the solutions given. I was on the verge of giving up and uninstalling the game when I started thinking, and came up with a solution that worked for me.

Here's the problem that I had:
After installing and updating bf2 to the latest patch (1.1.5). The bf2 client would attempt to run, go into full screen and then crash. Modifying the shortcut to run in windowed mode would give an error saying "unknown dynamic option... 800x600".
Since no matter what I would do the client would always attempt to run in 800x600 resolution I thought id play around with my monitors resolution.

Solution: Add a custom 800x600 resolution to your monitor. Apply it and run bf2.
If that doesn't work. Try switching to GPU scaling on your graphic settings. I know both nvidia and ati have this option so just look for it.
After you have done this and get into the game. Go into the games video settings and set it to a higher resolution. Then you can go back to your monitors native res.

Added:

Installing the game in other partion than system one or installing it in users\public folder may also help so you dont worry anymore about game folder rights.

 

Hope this helps.

Edited by WarGhost
Forgot to add last line
  • Upvote 2

Share this post


Link to post
Share on other sites

if you have a nvidia graphics card try an older driver. I had problems with the last driver in another game. i could go into the menu but if i wanted to play i had a CTD.
When I reinstalled the previous driver everything was ok again.

Alternatively, you can also have a look in your nvidia / ati system control if everything is right. (right graphics card, surround, physix, all effects such as AA off) then you should delete the shader folder of pr ...

 

  • Upvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×