Jump to content
MATT

BMS graphics problems

Recommended Posts

I've been away from the game for awhile and I started it back up. At first my cockpit resolution was somewhere around 100x255 and googling around I found the solution to go into the desktop quicklauch properties and Disable full screen optimizations. That got my resolution back to 1980xmodern graphics but when I go into the cockpit I am literally getting 1-2 FPS.

I have played this game on this computer for years and years but now my computer is acting like it cant handle the game.

Any ideas?

Share this post


Link to post
Share on other sites

Could be a few things causing that issue...  Have you changed any hardware during your absence from playing BMS?  What version did you leave on (did you have to update when coming back?)

I just got back into it myself, reinstalled after backing up my files, configs... but there could be so many simple things causing an issue that it might be hard to run through one at a time back and forth in a forum.

 

Do you have other games installed? I ask because it would be great to check that any game will run correctly on your monitor at that resolution, and decent FPS -- that would make BMS the problem to narrow it down.

Not sure if this could be an issue with the DX9 file in the BMS config folders, it's been awhile and I'm rusty in places.  That could be a thing to google, wish I could remember.

 

You did the right thing with the Disable full screen optimizations.  Let's just be sure the GFX card is working and that some game will play, and move forward from there.

Share this post


Link to post
Share on other sites

Yeah it's been running other games fine, and some pretty demanding games like Skyrim, Fallout 4 and War Thunder etc.

From what I can remember there have been no new hardware added, I did switch from Windows 7 to Windows 10 awhile ago... I don't remember if I have played BMS since the Windows updates or not.

I didn't do any fresh installs since last time I played,  I am running BMS 4.33 UI.

Share this post


Link to post
Share on other sites

Go into bms setup graphics and make sure the correct vido gpu is selected. Could be set to a mobo gpu. Turning off cockpit shadows is good place to start increasing fps.

Share this post


Link to post
Share on other sites

Okay, so if other games are running just fine right now and BMS is not, and if you have reviewed your in-game graphics settings and they are correct, let's try the DX9 file thing...

Go to the programs folder the contains your BMS installation (your Program Files\Falcon BMS 4.33 U1\User\Config) and delete the file:  dx9display.dsp

Start up BMS and go to your setup and double check that GFX settings are correct, then go to Instant Action for a quick test.  Let us know if it worked.  Next step (AFAIK) would be to backup your logbook and user files, and reinstall BMS.  I hope that won't be needed, but in the end might be faster than any further bug hunts.

Share this post


Link to post
Share on other sites

Well I deleted and reinstalled 4.33 and I am still having problems. Literally maybe 1 frame per second, maybe less.

 

I might as well add that my computer has:

AMD Phenom II x4

4GB Ram

Windows 10 64-bit

ASUS GTX 570 graphics card.

 

My computer isn't state of the art but it shouldn't have any problems running this game.

 

Edited by MATT

Share this post


Link to post
Share on other sites

Can we assume that you've tried a test in BMS with all the graphics settings as low as possible to see if that increases the FPS?  If it doesn't, it would be an indicator that something is not set correctly somewhere or that there is a literal fault causing an inability to display and run that game correctly.  Double check your GFX card's settings, too, and be sure you're not trying to push something crazy like 8x Anti Aliasing or 16x Anisotropic filtering or something while trying to get more FPS in testing.  Need to get some sort of baseline to see where your computer is hanging up, because it should get low FPS if there was an issue, not pinned down to 1 FPS.  That sounds like the game is not doing something right.

 

Also, re. uninstalling, perhaps you may need to be sure everything uninstalled completely, or maybe you did so before reinstalling?  That would be important to be sure the fault doesn't carry over.  Lastly, I'd go through the BMS Launcher, select the Configuration option, and go through those line by line, ensuring any hardware options are set correctly for your system and that any heavy performance options are disabled for the remainder of testing.

This one is a real head scratcher, but I'd advise you to keep at it, trying different things, it could be something obvious staring us in the face, or something less so, but there is a solution to every problem if you keep working at it.

Share this post


Link to post
Share on other sites

Did you install a legitimate version of Falcon 4.0?  Still available on Steam for $9.95 : https://store.steampowered.com/app/429530/Falcon_40/

A few people have tried installing BMS with a cracked version of Falcon 4.0 and it wont work.

BluDKlot has all the updates here, install Falcon 4.0, then these  5 updates, your done! Should work without too much adjustment:


 

  • Like 1

Share this post


Link to post
Share on other sites

Oh yes and another thing which was helpful are SemlerPDX's configuration settings, which if you ask nicely he may point you to his screenshots. :P

Share this post


Link to post
Share on other sites

Ok, I got it figured out, the HDR Lighting option in the BMS Config was what was throwing my computer through a loop.

I went into the config and shut off anything graphics related and the game worked just fine. Once it was working I went into the config and turned on one graphics option at a time until I found what was crushing my performance.

It's a bit odd that that option was already selected and didn't seem to be causing problems before... Oh well, I got it figured out now. Thanks for all the help!

Now I'm going to have to spend the next hour going through my setting and trying to figure half the game out again.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×