Jump to content
FrankoIT

Weird Mouse stutter issue?

Recommended Posts

Hey fellas, it's me, I was going to make a post just to say I'm possibly back but unluckily there are some issues stopping me from enjoying the game.
I'm gonna link THIS VIDEO which is old but shows what it basically looks like when I move my mouse.
For some reason this doesn't seem to be a problem with my laptop, as when I walk around without moving the mouse the game is smooth and silky and runs at a stable 40 fps. And if I use the mousepad it also works perfectly and the screen moves around well (ignoring my 220 ping, which eventually I'll figure out how to fix). It's not even the mouse itself, as when I open the ESC menu it moves around perfectly. I thought the drawing tablet was messing it up but unplugging it didn't fix anything. I'd love some help, thanks!

 

Share this post


Link to post
Share on other sites

Could be the combination of and your mouse and your touchpad. Can you disable the touchpad and unplug other input devices such as joysticks. 

You might want to look over you controls and verify if an other controller is also not trying to send data. 

  • Upvote 1

Share this post


Link to post
Share on other sites

maybe an irq problem?
as double said, first try deactivating your touchpad (in the device manager)
modern operating systems share the available irq channels and use them several times. if your mouse shares a channel with the sound card or the graphics card, there could be such problems ...

try ALL USB ports through. most are housed on one controller (especially with laptops)
if the problem occurs with all ports try to uninstall all usb controllers in the device manager. then restart the computer and see if it helped. Alternatively, turn off the sound card and the resolution of the game and see if it will be better or different to narrow down the error ..

 

edit:

You should also try another mouse from another manufacturer ...

wireless mouse?

I have a similar problem when I put my phone between mouse and receiver ... in windows I notice nothing but in pr it stutters ...

Share this post


Link to post
Share on other sites

I wrote all these down and I'll try them once I get back home. My mouse isn't wireless, but this happened only now that I had my tablet plugged in.
It's gonna be a bummer if I have to restart my PC or do some steps before I can play PR after using the tablet.

Thank you everyone, I really hope I can fix this and the ping. I've missed PR.

Share this post


Link to post
Share on other sites

Well then it is surly an mouse input issue. Do you eject your tablet safely or just pull it out as 99% of the world does. 

Maybe check device manager and check if an additional input device is still present 

Share this post


Link to post
Share on other sites

Ok so I was playing today and it was working smoothly until I got to an area where my FPS dropped, Muttrah City in the middle of fighting.
The mousepad worked fine, I haven't disabled it yet because every now and then I use it still. This just confused me more. I played for a bit, like an hour and then the issue popped up again, Escape menu still works fine, even in the map the cursor moves freely.
I'm just confused now? Is it just the lag causing this? If I move it slowly it moves a little better. Don't know what to say about this.

Share this post


Link to post
Share on other sites

this sounds like a heat or graphics card problem for me.
take a program (like occt for example) which monitors the temperatures and let it run while playing. if the stuttering begins look if something goes too hot.

try if it is better / different if you put the details on low and play with a low resolution.

Share this post


Link to post
Share on other sites

Ok, I noticed that while I played the temperature rose a bunch. I don't know how this program works but the big graph called "Temperature" showed said temperature rising as soon as I started playing. The mouse stutter thing was pretty bad at a point, and I couldn't move the mouse. The thing is the rest of the game ran fine. I could still play and I had some fun, the issue didn't really come up much apart from every now and then.
I'm really not sure why this happens, and if you say it's the graphics card I have no clue what to do about that.

Share this post


Link to post
Share on other sites

you have to google how hot your processor is allowed to be. if the value comes near the upper limit it could be the problem.

the next time you have this problem use the touchpad and see if it is really better. if so, I would disable the mouse pad in the device manager and see if it is better.

You could also see if you have these problems in a local game.

you will have to narrow down the error ...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×