=VG= Blazer

Project Reality Update: Mumble and C++ Issues

18 posts in this topic

Posted (edited)

Several players have had issues regarding the new update and Mumble not working. You simply need to update Visual C++.

(Vincent - I hope this helps!)

---------------------------------------------------------------------------------------------------------------------------------------------

Please read the following thread; http://www.realitymod.com/forum/f604-pr-changelogs/145393-pr-bf2-v1-4-12-0-changelog.html.

 

I have also copied in the important text:

Important, due to an update to the mumble client, make sure you have Visual C++ Redistributable for Visual Studio 2015 installed! Download it here. This is also for those who get the 'Mumble_app.dll error -3' error. You need the vc_redist.x86.exe even if you have x64 system.
 

Now follow the link given: https://www.microsoft.com/en-US/download/details.aspx?id=48145

-------------------------------------------------------------------------------------------------------------------------------------

Follow these steps to download and install:

Step 1

Click download on the website

1.png

 

Step 2

Click next to vc_redistx86.exe then click next

2.png

 

Step 3

A pop-up should appear at the bottom of the screen and click Save as.

Now save the program onto the desktop and click save.

3.png

 

Step 4

Go onto the desktop and find the file (vc_redist.x86.exe)

 

Step 5

The following screen should pop up. Click the small box on the bottom left then click install.

Unfortunately I've already had this installed so I can only show the final steps - You just need to follow the prompts and finalise the installation.

4.png

 

--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Hope this helps, if anyone has got any questions, feel free to ask!

--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Special Thanks to DARKCOTTONTAIL:

"If you run into an issue when running the C++ installer that says you already have a newer version of C++ installed, you technically need to only uninstall the x86 version of C++ update shown in the following screenshot"

Delete.PNG

 

Special Thanks to DIGUELO:

"When updating the redistributable packs It is highly suggested amongst programmers that ALL redist packs from 2010 to today be installed for both x86 and x64 versions. The main reason is that calls to and from it usually assume youve been putting them in place since you were in the womb and consequently start looking for them in the drive. For the space they take up its worth it to have them all in place.

Those using VS 2010 and above check your updates for the changes manually dont expect Windows to do it for you. And any code you write I find is usually best written in one specific studio and specify what it is. OS only makes a damn if its not windows 10, but the more people that use the same syntax and compatability and redist packs will achieve better results.

Making a Self installer routine dont forrget the uninstall routine to clear everything out."

Edited by =VG= Blazer
UPDATE: Additional info from other users
12

Share this post


Link to post
Share on other sites

Thank you very much for this guide!  Extremely helpful!

2

Share this post


Link to post
Share on other sites

If you run into an issue when running the C++ installer that says you already have a newer version of C++ installed, you technically need to only uninstall the x86 version of C++ update shown in the following screenshot.   I  removed both the updates on Vincents computer and was able to run the installer afterward.   

Delete.PNG

5

Share this post


Link to post
Share on other sites

@DarkCottonTail Thanks for your assistance earlier.

Ill definitely be using TeamViewer next time another user has technical issues.

3

Share this post


Link to post
Share on other sites

Really great guide, as well as i can help anyone that needs help as well as i had this problem and i got it fixed earlier today.

2

Share this post


Link to post
Share on other sites

Many people is having this issue from the last update (including myself). Installing vc_redist.x86.exe fixed the problem for me too.

2

Share this post


Link to post
Share on other sites

MasterRace Windows 7 posed 0 issues for me. 

3

Share this post


Link to post
Share on other sites

Windows 10 Home here, no problems with Mumble since the update.  Is the problem OS version specific?  It seems random...

1

Share this post


Link to post
Share on other sites
17 minutes ago, =VG= SemlerPDX said:

Windows 10 Home here, no problems with Mumble since the update.  Is the problem OS version specific?  It seems random...

No, its the fact that some people has got Visual C++ already from playing other games (As some games install Visual C++ for you when installing a game)

Some people don't have (The Correct) Visual C++ installed so therefore the Mumble Error occurs.

I'm not sure why they ask for the X86 Version installed (Probablty because mumble works with 32 bit atm so they have to use 32 bit Visual C++?)

 

1

Share this post


Link to post
Share on other sites
1 hour ago, Sausag3 said:

No, its the fact that some people has got Visual C++ already from playing other games (As some games install Visual C++ for you when installing a game)

Some people don't have (The Correct) Visual C++ installed so therefore the Mumble Error occurs.

I'm not sure why they ask for the X86 Version installed (Probablty because mumble works with 32 bit atm so they have to use 32 bit Visual C++?)

 

Thats weird tho because (And i know PR ships with 32-bit mumble) but mumble also comes with 64-bit variant on there site, So it would make sense that the 64-bit one would work too.

0

Share this post


Link to post
Share on other sites

Nice job  : ) much better than a kid on youtube  : ) at laast were saved, A++  

I give you narwhal horn as a gift  : )   good for hunt Python lolzz

cb76dea2ae49bcbb812a4ceeedc9c697.jpg

0

Share this post


Link to post
Share on other sites

Being a programmer I would like to draw your attention to the above post. When updating the redistributable packs It is highly suggested amongst programmers that ALL redist packs from 2010 to today be installed for both x86 and x64 versions. The main reason is that calls to and from it usually assume youve been putting them in place since you were in the womb and consequently start looking for them in the drive. For the space they take up its worth it to have them all in place.

Those using VS 2010 and above check your updates for the changes manually dont expect Windows to do it for you. And any code you write I find is usually best written in one specific studio and specify what it is. OS only makes a damn if its not windows 10, but the more people that use the same syntax and compatability and redist packs will achieve better results.

Making a Self installer routine dont forrget the uninstall routine to clear everything out. I learned the hard way back in the 80's about that with files left in folders and getting the wrong data.

Anyhow, issues involving C++ shoudlnt be issues its rarely even changed since 2002

I am willing to assist you if necessary but that is up to you. Contactme on my message inbox or on discord etc.

2

Share this post


Link to post
Share on other sites

Thanks for the info @Diguelo.

I will update my original post with the information you have provided.

0

Share this post


Link to post
Share on other sites

Posted (edited)

Hey ! Can somebody help me with some kind of errors ( 1.  vcredist 2015 error 0x80240017) . He just installed pr and the game crashes instantly when he selects kits (* this is the ingame error 2.  "Can't start because api-ms-win-crt-runtime-l1-1-0.dll is missing from your computer....mumble_app.dll missing" )..

Update: the game can be played only with mumble off

:hi:

Edited by .Blizzard.
1

Share this post


Link to post
Share on other sites

Yer its the C++ mumble crash, lots of tech wizard lingo on the post, and i like it but, please remember ,you need to have been exposed to computers in the womb, to chat python xp root folder options.  Blizzard.  just follow the steps shown at the top of the post by, =VG= Blazer and all will solved  : ) 

I had exactly the same mumble crash/ mumble off and game working symptoms.  

simplified version 

1 open link   https://www.microsoft.com/en-US/download/details.aspx?id=48145

2 click the download button 

3 select  vc_redist.x86.exe

4 run it and your good to go  : ) ) 

love the CHEM gear, i'm waiting for gean mods 

Adwww.oxfordgenetics.com/custom/cloning

1431030710_roguetrooper2006.jpg

love  VG xx

0

Share this post


Link to post
Share on other sites

It would have been too easy if that was it but it s not ... Non of those steps helped me i found that i need net Framework or something like that in order to run properly ...But thx for the reply 

1 hour ago, STRONTIUM_DOG said:

Yer its the C++ mumble crash, lots of tech wizard lingo on the post, and i like it but, please remember ,you need to have been exposed to computers in the womb, to chat python xp root folder options.  Blizzard.  just follow the steps shown at the top of the post by, =VG= Blazer and all will solved  : ) 

I had exactly the same mumble crash/ mumble off and game working symptoms.  

simplified version 

1 open link   https://www.microsoft.com/en-US/download/details.aspx?id=48145

2 click the download button 

3 select  vc_redist.x86.exe

4 run it and your good to go  : ) ) 

love the CHEM gear, i'm waiting for gean mods 

Adwww.oxfordgenetics.com/custom/cloning

1431030710_roguetrooper2006.jpg

love  VG xx

 

0

Share this post


Link to post
Share on other sites

Hay cool just also be sure your selecting the  86x version not the 64x  thing , as net framework will go bonk. 

The constant battle with a  PC, is a unique and personal crusade, may the force be with you.   

 

0

Share this post


Link to post
Share on other sites
14 hours ago, STRONTIUM_DOG said:

Hay cool just also be sure your selecting the  86x version not the 64x  thing , as net framework will go bonk. 

The constant battle with a  PC, is a unique and personal crusade, may the force be with you.   

 

Thx but yep that s the one that i installed 

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now